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Powerful tools in Excel 
 
Not only will Excel add and subtract, but it can make words or sentences and 
make workbooks with calculations easier to read. 
 
Count vs. Counta vs. Countif 
 
Count - Counts the number of cells that contain numbers and numbers within the 
list of arguments. Use COUNT to get the number of entries in a number field in a 
range or array of numbers. 
 
Counta - Counts the number of cells that are not empty and the values within the 
list of arguments. Use COUNTA to count the number of cells that contain data in 
a range or array. 
 
Countif - Counts the number of cells within a range that meet the given criteria. 
 
Examples 

Suppose A3:A6 contain "apples", "oranges", "peaches", "apples", respectively: 

COUNTIF(A3:A6,"apples") equals 2 

Suppose B3:B6 contain 32, 54, 75, 86, respectively: 

COUNTIF(B3:B6,">55") equals 2 

Trim 
 
Removes all spaces from text except for single spaces between words. Use 
TRIM on text that you have received from another application that may have 
irregular spacing.  This is especially useful when doing text matching. 
 
Example 
TRIM(" First   Quarter   Earnings   ") = "First Quarter Earnings" 
 
 
Concatenation 
 
Sometimes, a number is best placed within a sentence on a spreadsheet. To do 
this, use the “&” symbol to add strings and numbers together. 
 
Example: 
 

 In A1 Type 2 
 In A2 Type 2 
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 In A3 Type =A1+A2 
 In A4 Type =”The quantity” & A1 & “+” & A2 & “=” & A3 

 
Ceiling, Floor  
These functions make round up (ceiling) or down (floor) depending how they are 
called. 
 
Example 
How many cars are needed if each car can fit 4 people and we have 23 people? 
Example 
How many dollars do we have if we have 235 pennies? 
 
Today 
 
Gives the current date.  This field is updated every time the spreadsheet is 
updated (like on load). 
 
Lookup 

A vector is a range of only one row or one column. The vector form of LOOKUP 
looks in a one-row or one-column range (known as a vector) for a value and 
returns a value from the same position in a second one-row or one-column 
range. Use this form of the LOOKUP function when you want to specify the range 
that contains the values you want to match. 

Example 
 
  A B  C 

1 Frequency Color   
2 4.14234 red   
3 4.19342 orange   
4 5.17234 yellow   
5 5.77343 green   
6 6.38987 blue   
7 7.31342 violet   
8       

 
LOOKUP(4.91,A2:A7,B2:B7) equals "orange" 
LOOKUP(5.00,A2:A7,B2:B7) equals "orange" 
LOOKUP(7.66,A2:A7,B2:B7) equals "violet" 
LOOKUP(7.66E-14,A2:A7,B2:B7) equals #N/A, because 7.66E-14 is less than the 
smallest value in the lookup_vector A2:A7 
 
Vlookup 
 
Searches for a value in the leftmost column of a table, and then returns a value in 
the same row from a column you specify in the table. Use VLOOKUP instead of 
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HLOOKUP when your comparison values are located in a column to the left of 
the data you want to find. 
 
Example 
 
  A B  C D 

1 Air at 1 atm pressure       
2 Density Viscosity Temp   
3 (kg/cubic m) (kg/m*s)*1E+05 (degrees C)   
4 0.457 3.55 500   
5 0.525 3.25 400   
6 0.616 2.93 300   
7 0.675 2.75 250   
8 0.746 2.57 200   
9 0.835 2.38 150   

10 0.946 2.17 100   
11 1.09 1.95 50   
12 1.29 1.71 0   

 
VLOOKUP (1, A4:C12, 1) equals 0.946 
VLOOKUP (1, A4:C12, 2) equals 2.17 
VLOOKUP (1, A4:C12, 3) equals 100 
VLOOKUP (.746, A4:C12, 3) equals 200 
VLOOKUP (0.1, A4:C12, 2) equals #N/A, because 0.1 is less than the smallest value in column A 
VLOOKUP (2, A4:C12, 2) equals 1.71 
 
Left, Right, Mid 
 
Left 
LEFT returns the first character or characters in a text string, based on the 
number of characters you specify. 
 
Right 
RIGHT returns the last character or 
characters in a text string, based on 
the number of characters you 
specify. 
 
Mid 
MID returns the characters from the 
middle of a text string, given a starting position and length. 
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Referencing Cells in Excel 
 
We are quite familiar with referencing particular cells in Excel.  When we copy 
formulas, the cell references change with the new cell location.  What if we didn’t 
want to change the location of the cell?  We can tell Excel to use an absolute 
reference.  This is denoted by putting a $ in front of both the column and the row. 
 
Example 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Subtotals 
 
Returns a subtotal in a list or database. It is generally easier to create a list with 
subtotals using the Subtotals command (Data menu). Once the subtotal list is 
created, you can modify it by editing the SUBTOTAL function. 
 
Example 
 
Open ListSort.xls in Beyond the Basics of Excel 
 

 Add a subtotal to the list on bundles and trees 
 Use the filter function 

 
Note: 
 
SUBTOTAL will ignore any hidden rows that result from a list being filtered. This 
is important when you want to subtotal only the visible data that results from a list 
that you have filtered. 

Compound  
Interest 5% 
 $1,000.00   $   50.00  
 $1,050.00   $   52.50  
 $1,102.50   $   55.13  
 $1,157.63   $   57.88  
 $1,215.51   $   60.78  
 $1,276.28   $   63.81  
 $1,340.10   $   67.00  
 $1,407.10   $   70.36  
 $1,477.46   $   73.87  
 $1,551.33   $   77.57  
 $1,628.89   $   81.44  
 $1,710.34   $   85.52  
 $1,795.86   $   89.79  

 
Now what happens if we want 5% and 6%?   
 
Copying the formula over creates a mess because it 
is looking at the 5% interest column!  To make sure 
that it is only looking at the Money column, put a $ in 
front of the column.  Now the formula will always look 
in the right place as the formula is being copied to 
the right. 
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 Macros 
 
Macros are simply small programs written in Visual Basic that do specific tasks.  
These macros can be created or downloaded and incorporated into a 
spreadsheet. 
 
In the View Tab of the Ribbon, Click on the Macros dropdown and Record 
New Macro 
 
Gets to the macro menu 
 

 Macros…    Alt+F8 
Shows the macros in the workbook.  

 Record New Macro… 
Allows a person to create macros even if you don’t know the language 

 Visual Basic Editor    Alt+F11 
This shows the language and commands used to create the macro 

 
 
 

 
 
Macro Window 
 
Hello World 
 
The first program customarily written by a new programmer is “Hello World!”.  
This program simply prints out Hello World.  To do this using Excel macros, 
 

 In the View Tab of the Ribbon, Click on the Macros dropdown and Record 
New MacroNew Macro 

      To Stop a Macro 
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o Name   
o Shortcut (ctrl and/or shift)   
o Store macro in… 
o Description (help others) 

 Enter in these commands 
o Name – HelloWorld 
o Shortcut – ctrl+w 
o Store macro in… (This workbook) 
o Description (Print out Hello World – First program) 

 Click OK 
 New Form comes up with a stop button 
 Type in Hello World! and click on the stop button. 
 Test it – in various places 

 
 
Hello World (part 2) 
 
It goes back to the same spot, regardless of where you start.  To make it relative, 
click on the red arrow right next to the stop button.  Follow the steps above and 
try again.  Did it work? 
 
Looking at the code 
 
The commands that are used to create the Hello World should look like the 
following: 
 
Sub HelloWorld2() 
' 
' HelloWorld2 Macro 
' Macro recorded 11/1/2003 by Don Bremer 
' 
' Keyboard Shortcut: Ctrl+w 
' 
    ActiveCell.FormulaR1C1 = "Hello World" 
    ActiveCell.Offset(1, 0).Range("A1").Select 
End Sub 
 
The ‘ marks represent comments and are not read by the computer. 
 
Structures of programming 
 
There are actually 3 structures to any programming language. They are: 

 Statement 
 Loop 
 Logical 
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To make a loop in a macro with a known number of times through, we can use 
the for command.  We can change the comands of the macro to read: 
 
    For i = 1 To 5 
     ActiveCell.FormulaR1C1 = "Hello World" 
     ActiveCell.Offset(1, 0).Range("A1").Select 
    Next 
 
This will write “Hello World” on the cell, move down one cell, and write “Hello 
World” again.  Try this…. 
 
 
Logicals will ask a question.  Depending on the answer, it will do a set of 
commands.  Take for example the last “Hello World” example.  Instead of having 
it say “Hello World” all 5 times, what if we have it say “Goodbye Cruel World!” on 
the last loop.  We can do that using the conditional (or if) statement: 
 
    For i = 1 To 5 
        If i = 5 Then 
            ActiveCell.FormulaR1C1 = "Goodbye Cruel World!" 
        Else 
            ActiveCell.FormulaR1C1 = "Hello World" 
        End If 
      
     ActiveCell.Offset(1, 0).Range("A1").Select 
   Next 
 
Sort Worksheets using Macros 
 
In this exercise, we will create a macro from scratch.  This macro can then be 
called from another.   
 

 Start a new workbook 
 In the View Tab of the Ribbon, Click on the Macros dropdown and Record 

New Macro 
 Type in the code below: 

 
Sub SortSheets() 
 
Dim SheetCount As Integer 
Dim i As Integer 
Dim j As Integer 
 
    SheetCount = Worksheets.Count 
     
    If SheetCount = 1 Then 

 Exit Sub 
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    End if 
     
    For i = 1 To SheetCount - 1 
        For j = i + 1 To SheetCount 
            If Worksheets(j).Name < Worksheets(i).Name Then 
                Worksheets(j).Move Before:=Worksheets(i) 
            End If 
        Next j 
    Next i 
 
 
End Sub 
 

 Create another macro that calls this macro by writing: 
 
Sub Caller() 
 

' MsgBox shows something on the screen in a window 
     MsgBox ("Preparing to Sort Sheets")  
 ' Our macro     

SortSheets                           
     

MsgBox ("Sheets Sorted") 
 
End Sub 
 
 
 
Pivot Tables 
 
A PivotTable report is an interactive table that you can use to quickly summarize 
large amounts of data. You can rotate its rows and columns to see different 
summaries of the source data, filter the data by displaying different pages, or 
display the details for areas of interest You can start a Pivot table by opening the 
Pivot Table toolbar and clicking on the wizard. 
 
Example 
 

 Sorting Lists from class 2 of Excel 
 Northwind database in access 

 
 
 
Breaking the screen into frames 
 
Selecting the tabs on the top slider and the bottom slider will allow the user to 
open up 4 different panes that can be in 4 separate sections of the worksheet. 
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Common Error Types 
 
 
Error Description 
#NULL!   The formula contains a null (probably as a reference).  Is your 

formula complete? 
#DIV/0 The formula contains a division by 0.  Are two pieces the same 

value?  Is your formula correct? 
#VALUE! A textual value of a cell or an incorrect argument has been used 

in the calculation. While there are other possibilities for 
receiving this error, these two are the most common. 

#REF! The value in the referenced cell is no longer available in the 
formula. The cells, rows, or columns may have been deleted 
that were used in the formula. 

#NAME? A formula is not entered correctly. The defined name used may 
not exist, has been deleted or misspelled, or the quotes around 
text may have been omitted. 

#NUM! There is a problem with a number. Excel cannot interpret it 
because it is too small or too big or may not exist. Check for 
incorrect argument types in a function. 

#N/A This can signify several problems, depending on the formula.  

 No value was available (as in a lookup function). 

 It is being used as a placeholder when data is not yet 
available. 

 Charting features ignore this, so it is often used when you 
are charting data. To leave the cells empty would distort 
the chart, so use #N/A to prevent a 0 value. 

 
 
 
Transpose (Matrices) 
 
Say you have a column of numbers/letter and want them to become columns 
themselves.  You can do this by transposing the matrix. 
 

 Select the column 
 Copy to the clipboard 
 Go to the new location 
 Go to Paste Special… 
 Paste while checking the Transpose checkbox 
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Example 
 
Abe 
Ben 
Carl 
Dave 
Edward 
 
Can become…. 
 
Abe Ben Carl Dave Edward 
 
 
 
 
 
Breaking apart formulas 
 
Remember the Quadratic Formula in Algebra? 
 

 
has the solutions  

 

 
Program this? Yick!  It might be easier to break it apart to get the answer: 
 
A1: a 
A2: b 
A3: c 
 
Now break apart the formula: 
 
A5: -A2 
A6: ((A2^2)-(4*A1*A3))^0.5 
A7: 2*A1 
 
Answers: 
 
A8: (A5-A6)/A7 
A9: (A5+A6)/A7 
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Text to Columns 
Use this method if your names have a delimited format, such as "First_name 
Last_name" (where the space between First_name and Last_name is the 
delimiter) or "Last_name, First_name" (where the comma is the delimiter). 
 

 
 

1. Select the range of data that you want to convert.  

2. On the Data tab, in the Data Tools group, click Text to Columns.  

3. In Step 1 of the 

Convert Text to 

Columns Wizard, 

click Delimited, and 

then click Next.  

4. In Step 2, select the 

Space check box, 

and then clear the 

other check boxes 

under Delimiters.  

5. Click Next.  

6. In Step 3, click a column in the Data preview box, and then click Text under 

Column data format.  

Repeat this step for each column in the Data preview box. 
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7. If you want to insert the separated content into the columns next to the full 

name, click the icon to the right of the Destination box, and then select the 

cell next to the first name in the list (B2, in this example). 

8. Click the icon to the right of the Convert Text to Columns Wizard. 
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Remove Duplicates 
 
When you remove duplicate values, only the values in the range of cells or table 
are affected. Any other values outside the range of cells or table are not altered 
or moved. 
 Caution    Because you are permanently deleting data, it's a good idea to copy 
the original range of cells or table to another worksheet or workbook before 
removing duplicate values. 
 

1. Select the range of cells, or make sure that the active cell is in a table.  
2. On the Data tab, in the Data Tools group, click Remove Duplicates.  

 
 

3. Do one or more of the 
following:  

 Under Columns, select 
one or more columns.  

 To quickly select all 
columns, click Select 
All.  

 To quickly clear all columns, click Unselect All.  
If the range of cells or table contains many columns and you want to only select a 
few columns, you may find it easier to click Unselect All, and then under 
Columns, select those columns. 
 

4. Click OK.  
A message is displayed indicating how many duplicate values were removed and 
how many unique values remain, or if no duplicate values were removed. 
 

5. Click OK. 
 
 
Naming Ranges 
 
A Named Range is way to describe your formulas. So you don't have to have this 
in a cell: 
 

= SUM(B2:B4) 
 
You can replace the cell references between the round brackets. You replace 
them with a descriptive name, all of your own. So you could have this, instead: 
 

= SUM(Monthly_Totals) 

Behind the Monthly_Totals, though, Excel is hiding the cell references. We'll see 
how it works, now. 
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Open up Excel 2013, and create the spreadsheet below: 

 
 

Select the Monthly Totals from B2:B4 and where it says B2 on the formula bar, 
type “Monthly_Totals” 

 
 

 
Now you can refer to that range as Monthly_Totals, no matter how big it is. 
 

= SUM(Monthly_Totals) 
 
Getting Information from the Web 
 
The premise behind how you query stock information in your web browser 
ultimately boils down to the URL address.  Here is the standard URL address 
formula with two inputs (the Ticker Symbol and the Data Type). 
 
Breakdown Of The Yahoo! Finance Query URL 
 
https://download.finance.yahoo.com/d/quotes.csv?s=[Ticker Symbol]&f=[Data Type] 
 
So, let’s get the historical data on Microsoft 
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Go to finance.yahoo.com and apply the current time period: 
https://finance.yahoo.com/quote/MSFT/history?period1=1475081729&period2=1
506617729&interval=1d&filter=history&frequency=1d 
 
Then, go to Data->Get Data-> From Web 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Then, grab the right table! 
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The period is the number of seconds since 1970 (If you would like to build this by 
yourself). 
 

Example 1: Pull The "Current Stock Price" for Microsoft's Stock 

=NUMBERVALUE(WEBSERVICE("https://download.finance.yahoo.com/d/quotes.c

sv?s=MSFT&f=l1")) 

Example 2: Pull The "Current Dividend" for Microsoft's Stock 

=NUMBERVALUE(WEBSERVICE("https://download.finance.yahoo.com/d/quotes.c

sv?s=MSFT&f=d")) 
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Stock 
Pricing 

 

 
Averages 

 Variable  Description 
 

Variable Description 
a  Ask 

 

c8 After Hours Change (Real-time) 

b  Bid 

 

c3 Commission 

b2  Ask (Real-time) 

 

g Day’s Low 

b3  Bid (Real-time) 

 

h Day’s High 

p  Previous Close 

 

k1 Last Trade (Real-time) With Time 

o  Open 

 

l Last Trade (With Time) 

c1  Change 

 

l1 Last Trade (Price Only) 

c  Change & Percent Change 

 

t8 1-Year Target Price 

c6  Change (Real-time) 

 

m5 Change From 200 Day Moving 
Average 

k2  Change Percent (Real-time) 

 

m6 % Change From 200 Day Moving 
Average 

p2  Change in Percent 

 

m7 Change From 50 Day Moving 
Average 

d1  Last Trade Date 

 

m8 % Change From 50 Day Moving 
Average 

d2  Trade Date 

 

m3 50-Day Moving Average 

t1  Last Trade Time 

 

m4 200-Day Moving Average 

 

 

Dividends  
 

Volume 
 Variable  Description 

 
Variable Description 

y  Dividend Yield 

 

v Volume 

d  Dividend per Share 

 

a5 Ask Size 

r1  Dividend Pay Date 

 

b6 Bid Size 

q  Ex-Dividend Date 

 

k3 Last Trade Size 

 

 a2 Average Daily Volume 

 

 

 52-Week Pricing 
 

Ticker Related Information 
Variable  Description 

 
Variable Description 

k  52-Week High 

 

i More Info 

j  52-Week Low 

 

j1 Market Capitalization 

j5  Change From 52-Week Low 

 

j3 Market Cap (Real-time) 

k4  Change From 52-Week High 

 

f6 Float Shares 

j6  Percent Change From 52-
Week Low 

 

n Name 

k5  Percent Change From 52-
Week High 

 

n4 Notes 

w  52-Week Range 

 

s Symbol 

g1  Holdings Gain Percent 

 

s1 Shares Owned 
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g3  Annualized Gain 

 

x Stock Exchange 

g4  Holdings Gain 

 

j2 Shares Outstanding 

g5  Holdings Gain Percent (Real-
time) 

 g6  Holdings Gain (Real-time) 

  

 Financial Ratios 
 

Miscellaneous 
 Variable  Description 

 
Variable Description 

e  Earnings per Share 

 

t7 Ticker Trend 

e7  EPS Estimate Current Year 

 

t6 Trade Links 

e8  EPS Estimate Next Year 

 

i5 Order Book (Realtime) 

e9  EPS Estimate Next Quarter 

 

l2 High Limit 

b4  Book Value 

 

l3 Low Limit 

j4  EBITDA 

 

v1 Holdings Value 

p5  Price / Sales 

 

v7 Holdings Value (Realtime) 

p6  Price / Book 

 

s6  Revenue 

r  P/E Ratio 

 

w1 Day’s Value Change 

r2  P/E Ratio (Real-time) 

 

w4 Day’s Value Change (Realtime) 

r5  PEG Ratio 

 

p1 Price Paid 

r6  Price / EPS Estimate Current 
Year 

 

m Day’s Range 

r7  Price / EPS Estimate Next 
Year 

 

m2 Day’s Range (Realtime) 

s7  Short Ratio 

 

c4 Currency 
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Statistics 

Even though it seems that the makers of 
Excel put the kitchen sink in and reasdy to 
go – not everything is visible.  There is 
another statistical package that is an Add-
In if you want to go even further. 

File->Options->Add-Ins->Manage Excel 
Add-ins (Go…) 

Select on Analysis ToolPak and click OK
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A new item appears under data called “Data Analysis”.  When the item is 
selected, it shows the different things you can do: 

 

 

Moving Average example: 

The following illustration shows a summary of Contoso Pharmaceutical's 
inventory for their 10 best-selling products from last year. This report shows a 
large variance in the ending inventory quantities from month to month, indicating 
both shortages and stagnant product — neither of which is good for business. 
With a few simple steps, you can use this information to manage your inventory 
levels more precisely this year. 

Prod_ID Aug Sep Oct Nov Dec Jan Feb Mar Apr May Jun Jul 
1176 96 10 10 72 72 60 60 14 2 93 94 26 

401 19 11 4 47 47 69 52 13 13 56 64 75 
1482 78 11 7 46 5 30 30 19 9 100 90 74 
1548 96 11 0 99 99 74 74 18 1 73 18 74 
1406 48 13 65 99 99 46 46 16 16 94 33 58 
1517 3 13 13 26 26 92 92 10 1 44 18 47 

301 15 15 32 55 55 17 8 46 8 59 69 84 
303 32 18 41 65 65 11 11 50 1 72 43 51 
688 46 18 0 -20 26 75 75 15 1 23 99 49 
786 43 18 65 94 92 85 85 35 3 82 91 23 

The Moving Average analysis tool projects values in the forecast period, based 
on the average value of the variable over a specific number of preceding periods. 
A moving average provides trend information that a simple average of all 
historical data would mask. This example uses the data for Contoso product 
1176 to predict a target inventory level for the new fiscal year. 
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1. On the Tools menu, click Data Analysis. 
2. In the Data Analysis dialog box, click Moving Average, and then click OK. 
3. The Moving Average dialog box opens.  

 
4. In the Input Range box, enter a single row or column of data. This 

example uses the row of data from product 1176 on the Contoso top-10 
products report. 

5. In the Interval box, enter the number of values that you want to include in 
the moving average. In this example, enter 3, the default interval. 

 NOTE   The interval is the number of data points used to calculate the 
moving average. The larger the interval, the smoother the moving average 
line; the smaller the interval, the more the moving average is affected by 
individual data point fluctuations. 
 

6. In the Output Range box, enter the cell address where you want the 
results to start. 

7. Select the Chart Output check box to see a graph comparing the actual 
and forecasted inventory levels. 

8. Click OK. 
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Linest 
Returns statistics that describe a linear trend matching known data points, by 
fitting a straight line using the least squares method. 
 
The equation for the line is: 
y = mx + b 
 
 
Example 1 
Take for example the linear regression of sales per month 
 
Month Sales 

1 3100 
2 4500 
3 4400 
4 5400 
5 7500 
6 8100 

 
 
Answer: 1000 
 
What is the sales on the 9th month? 
Sales = 1000* 9 = 9000 
 
 
 
 
 
Example 2 – Multiple Linear Regression (the world is not linear) 
Suppose a commercial developer is considering purchasing a group of small 
office buildings in an established business district. 
 
The developer can use multiple linear regression analysis to estimate the value 
of an office building in a given area based on the following variables. 
 

VARIABLE REFERS TO THE 

y Assessed value of the office building 

x1 Floor space in square feet 

x2 Number of offices 

x3 Number of entrances 

x4 Age of the office building in years 
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This example assumes that a straight-line relationship exists between each 
independent variable (x1, x2, x3, and x4) and the dependent variable (y), the 
value of office buildings in the area. 
 
The developer randomly chooses a sample of 11 office buildings from a possible 
1,500 office buildings and obtains the following data. "Half an entrance" means 
an entrance for deliveries only. 
 

Floor space (x1) Offices (x2) Entrances (x3) Age (x4) Assessed value (y) 

2310 2 2 20 142,000 

2333 2 2 12 144,000 

2356 3 1.5 33 151,000 

2379 3 2 43 150,000 

2402 2 3 53 139,000 

2425 4 2 23 169,000 

2448 2 1.5 99 126,000 

2471 2 2 34 142,900 

2494 3 3 23 163,000 

2517 4 4 55 169,000 

2540 2 3 22 149,000 

 
 
Formula 
 
=LINEST(E2:E12,A2:D12,TRUE,TRUE) 
 
NOTE:  The formula in the example must be entered as an array formula. After 
copying the example to a blank worksheet, select the range A14:E18 starting 
with the formula cell. Press F2, and then press CTRL+SHIFT+ENTER. If the 
formula is not entered as an array formula, the single result is -234.2371645. 
 
When entered as an array, the following regression statistics are returned. Use 
this key to identify the statistic you want. 
 

 
 
The multiple regression equation, y = m1*x1 + m2*x2 + m3*x3 + m4*x4 + b, can 
now be obtained using the values from row 14: 
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y = 27.64*x1 + 12,530*x2 + 2,553*x3 - 234.24*x4 + 52,318 
 
The developer can now estimate the assessed value of an office building in the 
same area that has 2,500 square feet, three offices, and two entrances and is 25 
years old, by using the following equation: 
 
y = 27.64*2500 + 12530*3 + 2553*2 - 234.24*25 + 52318 = $158,261 
 
Or you can copy the following table to cell A21 of the example workbook. 
 
FLOOR SPACE 
(X1) OFFICES (X2) ENTRANCES (X3) AGE (X4) ASSESSED VALUE (Y) 

2500 3 2 25 52317.83051 
 
Assessed Value Y 
=D14*A22 + C14*B22 + B14*C22 + A14*D22 + E14 
 
Solver 
 
The idea behind the solver is to optimize a process or question.  To do this, we 
usually have multiple equations and multiple unknowns.  It is the solver’s duty to 
take these equations and optimize the results to get the best overall answer that 
you define.  That’s right – you have to tell it what it is looking for before it can find 
it! 
 
An optimization model has three parts: the target cell, the changing cells, and the 
constraints. 
 
Target cell  
The target cell represents the objective or goal. We want to either minimize or 
maximize the target cell. 
 
Changing cells 
Changing cells are the spreadsheet cells that we can change or adjust to 
optimize the target cell. 
 
Constraints 
Constraints are restrictions you place on the changing cells 
 
Installing and Running the Solver 
To install the Solver, go to the Options Panel->Add-Ins->Go… 
 
This is the same as getting the analysis Toolpak – but in this case, we want the 
Solver Add-in.  When it is installed, we will see a new “Solver” button in the 
Analysis section of the Data tab. 
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I’ve set up a spreadsheet that we will use to find the maximum profit while 
creating a certain amount of pallets using the solver.  You can download this file 
from donneray.info/excel. It is named pallet-solver.xlsx 
 

 
 
Creating your own worksheet should be done in a similar fashion – where the 
target cells and the changing cells are arranged in some logical fashion and are 
marked – making it easier to see what you are doing. 
 
In this worksheet, B4:E4 are the changing cells which represent our decision 
variables representing the number of pallets of each type of panel to produce.  
The solver will determine the optimal values for these cells. 
 
Notice that the profit for each pallet of panels ($450, $1,150, $800 and $400) was 
entered in cells B5, C5, D5 and E5, respectively. This allows us to compute the 
target cell in F5 as: 
 
=B5*B4+C5*C4+D5*D4+E5*E4 
Or equivalently, 
=SUMPRODUCT(B5:E5,B4:E4) 
 
In cells B8:E11, we've entered the amount of resources needed to produce a 
pallet of each type of panel. For example, the value 15 in cell C9 means that 15 
hours of pressing is required to produce a pallet of Pacific style panels. 
 
With these values in place, we can enter a formula in cell F8 to compute the total 
amount of glue used for any number of pallets produced: 
 
        Formula for cell F8:    =SUMPRODUCT(B8:E8,$B$4:$E$4)  
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With these values in place, we can enter a formula in cell F8 to compute the total 
amount of glue used for any number of pallets produced: 
 
        Formula for cell F8:    =SUMPRODUCT(B8:E8,$B$4:$E$4) 
 
We can copy this formula to cells F9:F11 to compute the total amount of 
pressing, pine chips, and oaks chips used. (The dollar signs in $B$4:$E$4 
specify that this cell range stays constant, while the cell range B8:E8 becomes 
B9:E9, B10:E10, and B11:E11 in the copied formulas.) The formulas in cells 
F8:F11 correspond to the left hand side values of the constraints. 
 
In cells G8:G11, we've entered the available amount of each type of resource 
(corresponding to the right hand side values of the constraints).  This allows us to 
express the constraints as: 
 
$F$8:$F$11<=$G$8:$G$11 
 
This is equivalent to the four constraints: F8<=G8, F9<=G9, F10<=G10, and 
F11<=G11. We can enter this set of constraints directly in the Solver dialogs 
along with the non-negativity conditions:  
 
        $B$4:$E$4>= 0 
 
To let the Solver know which cells on the worksheet represent the decision 
variables, constraints and objective function, we click Solver button on the Data 
tab, which displays the Solver 
Parameters dialog. In the Set 
Objective (or Set Target Cell) 
edit box, we type or click on 
cell F5, the objective function. 
In the By Changing Variable 
Cells edit box, we type B4:E4 
or select these cells with the 
mouse. 
 
To find the optimal solution, 
we simply click on the Solve 
button! 
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At this point, it asks to keep the solution or restore the values.  You can also get 
a report which describes the solution. 
 

 
 
Select the Outline Reports and 
click OK.  In Excel 2013, you get 
new tabs with all the information 
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Histogram Example 
 
Sometime the easiest way to see how the data 
falls is to use a histogram.  This takes a lot of 
data and puts it into bins.  Then, you count 
how many items have been put into those bins. 
 
Take for example, how many students in grade 
9 are a certain height?  How is this data 
distributed?  I’ve put this data into a file and 
you can download this file from 
donneray.info/excel. It is named pallet-
solver.xlsx 
 
So, click on Data Analysis, then Histogram: 

 
 

 
The input range is the all of the student’s heights.  The bin range contains range 
of items want to throw them in.  I made a container every 2 inches from below the 
minimum height. 
 
The Output gives the possibility of putting it on the sheet, in a new worksheet, or 
a new workbook.  I usually pick the new worksheet. 
 
It also gives the ability to add: 

 Pareto charts 
 Cumulative Percentages 
 Chart Output 
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Bin Frequency 
56 0 
58 0 
60 2 
62 2 
64 5 
66 5 
68 4 
70 4 
72 2 
74 1 

More 0 
 
 
 
Which, when graphed, makes it much easier to understand what is going on: 
 

 
 
 
Sampling 
 
Since I was just listening to the Car Talk guys talk about this, I thought this would 
be a good example to do! Sampling creates a sample from a population.  This is 
good, because we don’t have to test every single item, we can pick a 
representative sample from the data given. 
 
This example uses the Audit file which can be downloaded from 
donneray.info/excel.  

0

1

2

3

4

5

54-56 56-58 58-60 60-62 62-64 64-66 66-68 68-70 70-72 72-74

Students per height
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In this file, a company named Outlander Spices needs to audit 15 quarterly sales 
values for several stores.  The first step is to randomly select the 15 store and 
quarter combinations by using the Sampling analysis tool.   
 
The Sampling sheet contains a list of stores and quarters, with a combination of 
both combined in a column (because the Sampling tool requires that the 
information be numeric).  For example, 203 represents store 002’s third-quarter 
sales. 
 
Select Sampling from the 
Analysis Tools. 
 
In the Input Range box, enter 
C7:C66.   
 
Under Sampling Method, 
select Random. 
 
In the Number of Samples 
Box, Enter 20.  With 20 
samples, 15 or more are likely 
to be unique. 
 
Under the Output options, 
select Output Range and enter 
E7. 
 
 
Click OK! 
 
You now have 20 values to 
pick from, but some are 
duplicates. 
 
How do you remove the 
duplicates? 
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Scenarios 
 
Scenarios are sets of input values that produce different results.  For example, in 
a budget projection worksheet, you can have one scenario that includes 
conservative sales figures, and another scenario that includes more aggressive 
sales figures.  Instead of creating a new scenarios every time, you can modify 
existing scenarios.  In a worksheet containing multiple scenarios, you can switch 
among them to view the results for different input values.  In addition, you can 
merge scenarios from other worksheets. 
 
This example uses the Projections file which can be downloaded from 
donneray.info/excel.  
 
In the Scenarios sheet, select B8:E8 and then Data->What If Analysis-
>Scenario Manager.   

 
Click Add. 
 
In the Scenario name box, enter Original 
profit.  In the Comment box, edit the box to 
say: Original projected profit.   
 
Click OK.  
 
A box now comes up with all the original 
values.  Click on Add. 
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A new scenario box appears.  In this box, put in: 
Decreased cost of sales 
 
Edit this comment box to say: 
Projected profit with decreased cost of sales. 
 
Click OK. 
 
Enter the values as shown 
 

 
 
Click OK  
 
Now, you can select on any of the scenarios and it will automatically update the 
table to show the changes based on the scenario. 
 
If the scenario ended up being even better, one you can change the scenario by 
clicking it and selection Edit…. Edit the “Decreased cost of sales” scenario to the 
values below: 
 

 
 
Click OK.  Click Show.  Click Close. 
 
  



Page 36 of 36 

Goal Seek 
 
Even though you know the formula to something, sometimes you would like to 
adjust the numbers until you reach a desired outcome.  Take for example the 
payment of a home mortgage.  You may know what type of loan you want and 
the payment – yet, you would need to figure the percentage necessary to get that 
type of loan. 
 
Create a new worksheet and type: 

1. In cell A1, type Loan Amount. 
2. In cell A2, type Term in # of Payments. 
3. In cell A3, type Interest Rate. 
4. In cell A4, type Payment. 

 
Next, add the values you know 

1. In B1, type 100000 – this is the amount you want to borrow 
2. In B2, type 180 – the number of months to pay off the loan 

 
We know the equation for finding a mortgage payment is PMT.  In this case, we 
want to type this into B4: 
 
=PMT(B3/12,B2,B1) 
 
In this example, we want to pay $900/month.  We won’t enter that amount here, 
because you want to use Goal Seek to determine the interest rate, and Goal 
Seek requires that you start with a formula. 
 

1. On the Data tab, in the Data Tools group, click What-If Analysis, and then 
click Goal Seek. 

2. In the Set cell box, enter the reference for the cell that contains the 
formula that you want to resolve. In the example, this reference is cell B4. 

3. In the To value box, type the formula result that you want. In the example, 
this is -900. Note that this number is negative because it represents a 
payment. 

4. In the By changing cell box, enter the reference for the cell that contains 
the value that you want to adjust. In the example, this reference is cell B3. 

5. Click OK 
 
Remember to change the Number look into a 
percentage so that it makes sense. 
 
 
 
 


