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A database is the computer equivalent of an organized list of information.  Typically, this information has a common subject or purpose such as a list of employees.  The list is arranged in a table of columns and rows, called fields and records.  Each column or field stores a particular type of information about an employee such as name, address, etc.  Each row or record contains information about different employees.

A simple database program can store information in only one table, which is often referred to as a flat file.  Microsoft Access can store information in multiple related tables, which is often referred as a relational database.  If the information in a relational database is organized correctly, you can treat these multiple tables as a single storage area and pull information electronically from different tables in whatever order meets your needs.

Basics of Database Management-Microsoft Access
Learn how to create basic tables, forms, queries and reports to manage data and retrieve information quickly.

[bookmark: _Toc20639206]	Objectives:
· Understand and plan a database
· Become familiar with tables, forms, queries and reports
· Create a blank database 
· Work with a table, form, query and reports
[bookmark: _Toc20639207]
Understanding Databases
What is a database? A simple definition of a database is a collection of related information, similar to the files in a file cabinet. Database information is grouped in tables, which you can think of as file drawers. Each table contains individual records, just as a file drawer contains file folders.
· Uses or tasks
· Client/Customer Contacts
· Mailing Lists
· Information Tracking 
· Invoicing
· Asset Tracking
· Inventory Management
· Event Management
· Tour of Access Database
· Sample database included (Northwind Database)
 >From Microsoft Office Online > Sample > Northwind
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· Objects of Microsoft Access
· Tables (similar to drawers in a file cabinet)
A table is a collection of data about a specific topic, such as products or suppliers. A database is made up of at least one table, with columns for types of information and rows for individual records. Using a separate table for each topic means that you store that data only once, which makes your database more efficient, and reduces data-entry errors. 

Fields and Records (data is organized)

[image: ]

· Queries
You use queries to view, change, and analyze data in different ways. You can also use them as the source of records for forms, reports, and data access pages.
· Forms
Forms are used to make data entry easier.  Forms can include various fields from various tables.
· Reports
A report is an effective way to present your data in a printed format. Because you have control over the size and appearance of everything on a report, you can display the information the way you want to see it.
[bookmark: _Toc20639208]

Planning a Database

· Determine Need or Purpose
· What problem or need can this solve?
· Why do you need the database?
· What will it allow you to do better than you do now?
· Send Mailings to Customers
· Track orders
· What sort of output do you need to include?
· Deciding What Should be Included?
· What sets of information?
· Customers/Clients
· Employees/Salespersons
· Items sold
· Results of customer/client surveys
· Deciding on a Structure for Your Database
· Tables are the backbone of your database.
· Make sure the structure accomplishes your objectives.
· Enter a few records that are representative of your sample of data.
· Determining Table Fields
· Fields hold the information.
· Each data field must be part of a specific table.
· Every field should hold the smallest logical component.
· First Name
· Last Name
· Title
· Street Address
· City
· State
· Zip
· NOT Title, First Name and Last Name in one field
OR Address, City, State and Zip in another field
· Identifying Unique Fields
· Allows connection of tables in a relationship.
· Unique fields are only used once in a table (called Primary Key).
· Social Security Numbers
· Item numbers in a catalog
· Employee ID
· ISBN

· Deciding How Tables are Related: Understanding Relationships- Relationships link two tables by specifying a common field that appears in both tables.

· Review the Design and the Table Relationships
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Three types of relationships:

One-to-One
· In a one-to-one relationship, each record in Table A can have only one matching record in Table B, and each record in Table B can have only one matching record in Table A. This type of relationship is not common, because most information related in this way would be in one table. You might use a one-to-one relationship to divide a table with many fields, to isolate part of a table for security reasons, or to store information that applies only to a subset of the main table. For example, you might want to create a table to track employees participating in a fundraising soccer game.
One-to-Many (Most Common)
· One record in Table A can be related to many records in Table B one-to-many relationship.  An association between two tables in which the primary key value of each record in the primary table corresponds to the value in the matching field or fields of many records in the related table.  An example is the relationship between a Customers table and an Orders table, in which each customer can have many orders, but each order is related to only one customer.
Many-to-Many (Rarely Used-these are handled by building linking tables)
· A record in Table A can be related to many records in Table B, and a record in Table B can be simultaneously related to many records in Table A. An association between two tables in which one record in either table can relate to many records in the other table. To establish a many-to-many relationship, you need to create a third (junction) table and add the primary key fields from each of the other two tables to this table. For example, if you have a Products table and an Orders table, an order can include more than one product, and a product can be included in more than one order. You must create a junction table that has a one-to-many relationship with the Products table and a one-to-many relationship with the Orders table.
· Before you begin constructing, create design on paper and draw out the structure of your tables and relationships graphically

[bookmark: _Toc20639209]Launching /Exiting Microsoft Access

· Launching Microsoft Access
>Start Menu from Task Bar > Find… Access
Pick the first one
[image: ]
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Access and Fluent Basics

The new Microsoft Office 2007 Fluent user interface primarily consists of nine key components:

1. [image: ]The Ribbon - consists of tabs displaying the commands that are most relevant for each of the task areas in each application. This is a combination of the menu and toolbars.

2. Contextual Tabs - whenever a user selects or inserts an object, the Contextual Tabs for modifying that object (such as pictures, tables, text boxes and charts) appear in the Ribbon.
3. The Office Button - replaces the File menu.
4. [image: ]Galleries - provide users with a visual set of formatting options to choose from when working on a document, spreadsheet, presentation or Access database.
5. Live Preview - shows the potential results of a Gallery selection within the document before it is actually applied.
6. [image: ]Mini Toolbar - provides easy and efficient access to the most frequently used text-formatting commands.



Mini Toolbar


Gallery (Item #4)
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7. [image: ]Enhanced ScreenTips - appears as users move the mouse pointer over items in the Ribbon, showing the name of the feature, the keyboard shortcut and a brief description of what the feature is used for, and help links.
8. [image: ]Quick Access Toolbar - provides a single location for people to place the commands and features they use most frequently. 








9. KeyTips - appear in front of the Ribbon tabs with a single letter or combination of letters for users to type to activate the feature when users press the Alt key.



[bookmark: _Toc20639211]Opening an Existing Database-Entering and Updating Data in Forms

· Open Sweet Lil’s Database
>File Button >Open>My Documents>Basics of DBM >Sweet Lil
· Creating new records
· In the All Access Objects pane, click on Forms
· Double-click on Chocolate Preferences
· Using this form, enter the following information into a new record:
· Tab to move forward between fields
· Shift-Tab to move backwards between fields
· Records are saved as soon as you move the insertion point out of a record

	Field
	Data

	First Name
	Amanda

	Last Name
	Hart

	Address
	10 Melrose

	City
	Duluth

	State/Province
	MN

	Postal Code
	55805

	Country
	USA

	Date Received
	Automatically filled with predetermined data.  This field is skipped over.

	Chocolate Type
	Use the down or up arrow keys to select the option choice: 
Milk Chocolate
(note-when using radio buttons, only one of the choices can be selected)

	Nuts check box
	Press space bar to put check in Nuts check box (pressing space bar removes check…you can also click in the box with the mouse)


· Enter second record
· Either Tab when you are in the last field or
· Insert Menu>New Record or
· Click on the New Record button in the Navigating Between Records bar (bottom of window)
	Field
	Data

	First Name
	Rita

	Last Name
	Corquette

	Address
	300 Locust Avenue

	City
	Thousand Oaks

	State/Province
	CA

	Postal Code
	91320

	Country
	USA

	Chocolate Type
	Dark

	Nuts check box
	No


· Enter a third record
· Make up a record on your own
· Updating Existing Records
· Click on the Previous Record button on the Navigation bar
· Add Place to the end of 10 Melrose
· Click the mouse after the e in Melrose and type in the word Place.
· Click on the Next Record Button to save changes.
· Delete Existing Records
· Browse until you find the record you want to delete (choose the one you created on your own.
· From the Edit Menu or Toolbar, choose Delete Record
· Confirm
· Close the form
· Click the Close button for the Chocolate Preferences form
· Don’t click on the Close button in the extreme upper right-hand corner, that will close Microsoft Access
[bookmark: _Toc20639212]Entering Data Efficiently and Correctly
Combo boxes allow you to select values from a list (insures consistency).  Validations rules force you to enter amounts or dates between certain ranges, or information of a certain type.

· Open the Bonbon form
· Browse until you find the record “Candlelight Ecstasy” bonbon
· Change the following information:
	Field
	Data

	Filling Type Combo Box
	Click the drop-down and choose Marzipan

	Cost Field
	Type in 1.35 and tab
A message will tell you the value is too high.
Select the 1.35
Type in .35 and tab



· Close Bonbon form

[bookmark: _Toc20639213]Finding Records
· Open the Customer Review form
· Click in the Last Name Field
· From the Toolbar, click on the Find Button (binoculars) or 
· Use the keyboard shortcut Ctrl-F
· In the Find What text box, Type in Hemshire
· Select Last Name from the Look In list if it isn’t already selected
· Select Whole Field in the Match list, if it isn’t already selected
· Click on find next to see if there are any other matches
· Click OK and close dialog box

[bookmark: _Toc20639214]Working with Tables
· Viewing Data
· Datasheet View
· From the Object bar, Select Tables
· Double-click on Bonbons
· Changing the way information is viewed
· Maximize Window
· Adjust Height of Rows
· Position mouse pointer on border between any two records and when pointer becomes a double-headed arrow, hold mouse button down and drag border down.  This allows Bonbon Description to show.
· Adjust Width of Column
· Position mouse pointer on border between any two fields and when pointer becomes a double-headed arrow, hold mouse button down and drag border right.  Click between Nut Type and Filling Type decrease width of column.  (Double-click will Automatically fit cell)
· Reorder columns
· Select column
· Drag to new position
· Save Changes
[image: ]
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· Viewing Design Information


[bookmark: _Toc20639215]
Creating a New, Blank DatabaseMembership Database-XXXX


· File Button > New
· Choose the Blank Database button

[image: ]
· Name “Membership Database-XXXX” (where XXXX equals month and today’s date)
· Select View -> Design View
· Save the table as Membership
· Put the fields of the table as is shown below.

	Field Name
	Data Type
	Description

	NameID
	AutoNumber
	Number automatically assigned to new record

	Fname
	Text
	First Name

	Lname
	Text
	Last Name

	Address
	Text
	Address

	City
	Text
	City

	State
	Text
	State

	Zip
	Text
	Zip

	MemberDate
	Date/Time
	Membership Date

	Committee
	Lookup Wizard
	Current Committee served in club



Close the table and start a new one by clicking on the “Create” tab and clicking “Table”.
· Double-click the banner that says, “ID” and rename it to “CommitteeID”
· Double-click the banner that says, “Add New Field” and name it “Description”
· In the white table under the word Description, add the records for:
· Executive Board
· Finance
· Membership
· Programs
· Notice that CommitteeID is automatically numbered.
· Close the table and say “Yes” to save the changes
· Call the table “Committees”

Double-click the Membership table on the “All Tables” pane on the left site and then change the view to Design.  Now, add in the final column called, “CommitteeID” – which will of a type, “Lookup Wizard…”.
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· The information will be obtained from a table (Next >)
· From the table Committees (Next >)
· Select both fields the “Available Fields” box and move them over (Next >)
· No sorting order is necessary (Next >)
· The look is fine (Next >)
· And the label is fine.  Click “Finish”

Save the table and return to the table view.
· Enter in 5 of the entries from the table below
· Create a new Form
· Click on Create tab on the top of the Ribbon
· Click Form from the Ribbon
· A new form is already created in the design view.  Click the form view icon to use the form.  When asked, save the form as Membership.
	Fname
	Lname
	Address
	City
	State
	Zip
	MemberDate
	Committee

	Fred
	Jones
	10 Main Street
	Duluth
	MN
	55802
	12/5/97
	Executive Board

	Peter
	Smith
	55 West Melrose Place
	Superior
	WI
	54880
	4/3/95
	Executive Board

	Cathy
	Burns
	9843 Waverly Lane
	Duluth
	MN
	55804
	1/23/99
	Finance

	Tammy
	Frest
	34 North Oak
	Duluth
	MN
	55811
	4/25/00
	Membership

	Sam
	Anderson
	123 Main Street
	Superior
	WI
	54880
	1/10/97
	Finance

	Dana
	Johnson
	34 North 8th Street
	Duluth
	MN
	55804
	10/5/98
	Executive Board

	Paula
	Wilson
	135 Tower Avenue
	Superior
	WI
	55480
	1/23/99
	Membership

	Howard
	Snyder
	456 Central Entrance
	Duluth
	MN
	55811
	4/25/00
	Membership

	Karl
	Jablonski
	2020 East Superior Street
	Duluth
	MN
	55812
	1/10/97
	Programs

	Rene
	Phillips
	545 E. 5th Street
	Duluth
	MN
	55805
	10/5/98
	Programs

	Fran
	Wilson
	11 E. Superior Street
	Duluth
	MN
	55802
	1/23/99
	Finance


· Enter the data information for the remaining records 

· View data from the table
· Create a Query
· Click on the Create tab on the Ribbon
· Click Query Design from the Ribbon (under Other)
· Select all tables and Add, then Close
· [image: ]Include all fields
· Save this as “All People”
· Set Criteria to “MN” in state column
· Save this as “MN Members”
· 
Create a Report – Mailing Labels
· From the Objects dropdown, select Queries
· Click on the “All Members” Query
· Click on Create tab on the top of the Ribbon
· Click Labels from the Ribbon
· Click on New (on the toolbar for the Reports Window)
· Select Avery
· Select English
· Choose 5160
· Follow Wizard -Construct label
· Choose sort order
· Finish

· Create a Report –Members by Committee
· Select Reports from the Object Bar
· Select Create report by using wizard
· Choose “All Members” Table
· Choose all Fields
· Group by “Committee”
· Choose sort order
· Choose report layout
· Choose report style
· Name “Members by Committee”
· Finish

[bookmark: _Toc20639216]Creating a New Database Using a Wizard
· File>New>Templates>Databases Tab
· Double-click on Order Entry
· Save as Order Entry1
· Wizard choices
· Tables & fields in Database
· Style for Screen Display
· Style for Reports
· Database Title
· Picture for reports
· Start Database
· Click on Finish
· Enter Information
· Maximize Order Entry database
· Look at Tables
· Look at Queries
· Look at Forms
· Look at Reports 

[bookmark: _Toc20639217]
 Access Shortcuts

	Activity
	Shortcut Keys

	Copy
	CTRL+C

	Display the database window
	F11

	Find and replace
	CTRL+F

	Insert a carriage return in a memo or text field
	CTRL+ENTER

	Insert the current time
	CTRL+:

	Insert the data from the same field in the previous record
	CTRL+'

	Insert today's date
	CTRL+;

	Open a new database
	CTRL+N

	Open an existing database
	CTRL+O

	Paste
	CTRL+V

	Print
	CTRL+P

	Save
	CTRL+S

	Switch between the Visual Basic Editor and the previous active window
	ALT+F11

	Undo
	CTRL+Z

	Undo the changes you have made to the current field
	ESC

	Undo the changes you have made to the current record
	ESC ESC (press ESC twice)
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